Monday, March 30, 2009

Get Flash Player working once and for all on 64-bit Ubuntu

Flash on Linux until recently has been a vexing problem. Initially, there was no Flash plugin for Linux at all, so in order to use Flash one had to use the plugin via Wine. Since then, Adobe has stepped up to the plate, offering two different versions of Flash for Linux: a 32-bit stable release, and an alpha version of a 64-bit plugin. I’ll cover how to install each of these.

The first step in installing the Flash plugin is figuring out which one you want to use. In my experience, the 64-bit version has been a little unstable, but overall it isn’t bad. I would recommend this version first. If you use Flash a lot and want to avoid browser crashes at all costs, 32-bit Flash is the way to go. If you're looking for a better performance at the potential loss of some stability, 64-bit Flash is the better choice.

First, download Flash from the Adobe website. I’ve included a link to the appropriate page.

The current version as of 3/2009 is version . Therefore, the filename I downloaded is

Next, you need to unpack this file out the tar.gz so that you’re left with just a .so file. First, switch into the folder to which the file was downloaded. This is most likely either your home folder (open up the terminal type “cd” to switch to it) or your Desktop (go to your home folder then type “cd Desktop”. Make sure to capitalize the D) Next, give the command to decompress the

tar -xvzf

Replace the libflashplayer bit with the name of the file you’ve downloaded. This command can also be used with an tar.gz file.
Next, we need to move the newly extracted .so file to the appropriate location, in this case /usr/lib/firefox/plugins . As this will affect all users, it must be executed as root, so we throw sudo on the front.

sudo cp /usr/lib/firefox/plugins

After enter your password, the command will complete. Next, open Firefox and type “about:plugins” into the address bar and press enter. This will bring up a list of plugins that Firefox is using. Find the section for “Shockwave Flash” and make sure that the file listed is . If it is something else, you should use Synaptic to uninstall your previous version of the Flash plugin.

To install the 32-bit plugin, the process is a lot easier. The simplest way to do this is by using Synaptic to install it. This also ensures that receive updates to your plugin as they become available.


Post a Comment